已知树的前序和中序求后序 hdu 题目1710 Binary Tree Traversals

Binary Tree Traversals

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2448    Accepted Submission(s): 1066


Problem Description
A binary tree is a finite set of vertices that is either empty or consists of a root r and two disjoint binary trees called the left and right subtrees. There are three most important ways in which the vertices of a binary tree can be systematically traversed or ordered. They are preorder, inorder and postorder. Let T be a binary tree with root r and subtrees T1,T2.

In a preorder traversal of the vertices of T, we visit the root r followed by visiting the vertices of T1 in preorder, then the vertices of T2 in preorder.

In an inorder traversal of the vertices of T, we visit the vertices of T1 in inorder, then the root r, followed by the vertices of T2 in inorder.

In a postorder traversal of the vertices of T, we visit the vertices of T1 in postorder, then the vertices of T2 in postorder and finally we visit r.

Now you are given the preorder sequence and inorder sequence of a certain binary tree. Try to find out its postorder sequence.
 


 

Input
The input contains several test cases. The first line of each test case contains a single integer n (1<=n<=1000), the number of vertices of the binary tree. Followed by two lines, respectively indicating the preorder sequence and inorder sequence. You can assume they are always correspond to a exclusive binary tree.
 


 

Output
For each test case print a single line specifying the corresponding postorder sequence.
 


 

Sample Input
9 1 2 4 7 3 5 8 9 6 4 7 2 1 8 5 9 3 6
 


 

Sample Output
7 4 2 8 9 5 6 3 1

 

利用递归,从前序一个个元素开始,m=1; 在中序中找到in[i] == pre[m], 然后将中序分为两部分,in[1.....i-1]  和in[i+1.....n],然后分别遍历这两部分,直到这两部分元素为0(s>t) 或1个(s==t);

 

 

#include <iostream>
#include <stdio.h>
#include <stdlib.h>

using namespace std;

int m = 1;
int p = 1;
int pre[1003],in[1003],post[1003];

void Traverse(int s,int t)
{
    if(s>t) return;//空,没有元素
    if(s==t){//一个元素
        m++;
        post[p++] = in[s];
    //    printf("%d ",in[s]);
        return ;
    }
    int k,i;

    //printf("---------pre[%d]=%d\n",m,pre[m]);
    k = pre[m++];
    i= s;
    while(in[i++]!=k);
//    printf("i=%d\n",i);
    Traverse(s,i-2);
    Traverse(i,t);
    post[p++] = in[i-1];
//    printf("%d ",in[i-1]);

}
/*
9
1 2 4 7 3 5 8 9 6
4 7 2 1 8 5 9 3 6
*/
int main()
{
    int n,i;

    while(scanf("%d",&n)!=EOF)
    {
        for(i=1;i<=n;i++) scanf("%d",&pre[i]);
        for(i=1;i<=n;i++) scanf("%d",&in[i]);
    //    for(i=1;i<=n;i++) printf("%d ",pre[i]);
    //    for(i=1;i<=n;i++) printf("%d ",in[i]);
        Traverse(1,n);
    //    printf("\n");
        for(i=1;i<n;i++) printf("%d ",post[i]);
        printf("%d\n",post[n]);//这里格式问题!!!
        m=1;   p=1;  //每组测试数据都要将m,p初始化!!!
    }
    return 0;
}