ZOJ 题目1610 Count the Colors(线段树)

Count the Colors


 

Time Limit: 2 Seconds      Memory Limit: 65536 KB

Painting some colored segments on a line, some previously painted segments may be covered by some the subsequent ones.

Your task is counting the segments of different colors you can see at last.


Input

The first line of each data set contains exactly one integer n, 1 <= n <= 8000, equal to the number of colored segments.

Each of the following n lines consists of exactly 3 nonnegative integers separated by single spaces:

x1 x2 c

x1 and x2 indicate the left endpoint and right endpoint of the segment, c indicates the color of the segment.

All the numbers are in the range [0, 8000], and they are all integers.

Input may contain several data set, process to the end of file.


Output

Each line of the output should contain a color index that can be seen from the top, following the count of the segments of this color, they should be printed according to the color index.

If some color can't be seen, you shouldn't print it.

Print a blank line after every dataset.


Sample Input

5
0 4 4
0 3 1
3 4 2
0 2 2
0 2 3
4
0 1 1
3 4 1
1 3 2
1 3 1
6
0 1 0
1 2 1
2 3 1
1 2 0
2 3 0
1 2 1


Sample Output

1 1
2 1
3 1

1 1

0 2
1 1

 

没有使用线段树的代码:因为8000比较小,不然会超时

 

#include"stdio.h"
#include<string.h>

int main()
{
	int tree[8010];
	int finalcolor[8010];
	int n,i,j;
	int ls,rs,c;//临时的表示当前输入数据的左右范围及颜色 
	int rmax;//表示总的最右边界 
	while(scanf("%d",&n)!=EOF)
	{

		memset(tree,-1,sizeof(tree));
		rmax = 0;
		while(n--)//输入n个颜色,及其染色范围 
		{
			scanf("%d%d%d",&ls,&rs,&c);
			if(rs>rmax) rmax = rs;//从1开始的下标中存放的值表示前面一单位段的颜色 
			for(j=ls+1;j<=rs;j++)//后来输入的颜色会直接覆盖前面的颜色 
				tree[j] = c;
			
		}

		
		memset(finalcolor,0,sizeof(finalcolor));

		
		int k;
		j=0;
		finalcolor[tree[1]]=1;
		for(i=2;i<=rmax;i++)
		{	
			if(tree[i]==tree[i-1]) continue;	 
			finalcolor[tree[i]]++;
	
		}//for
		
		for(i=0;i<=8002;i++)
		{
			if(finalcolor[i])
				printf("%d %d\n",i,finalcolor[i]);
		} 
		printf("\n");
		
	}//while
	return 0;
}











/*
1
1 2 55

5
0 4 4
0 3 1
3 4 2
0 2 2
0 2 3
4
0 1 1
3 4 1
1 3 2
1 3 1
6
0 1 0
1 2 1
2 3 1
1 2 0
2 3 0
1 2 1
3
1 2 3
1 2 2
1 2 1

*/