POJ 题目2182 Lost Cows

 

 

Lost Cows
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 8263   Accepted: 5272

Description

N (2 <= N <= 8,000) cows have unique brands in the range 1..N. In a spectacular display of poor judgment, they visited the neighborhood 'watering hole' and drank a few too many beers before dinner. When it was time to line up for their evening meal, they did not line up in the required ascending numerical order of their brands.

Regrettably, FJ does not have a way to sort them. Furthermore, he's not very good at observing problems. Instead of writing down each cow's brand, he determined a rather silly statistic: For each cow in line, he knows the number of cows that precede that cow in line that do, in fact, have smaller brands than that cow.

Given this data, tell FJ the exact ordering of the cows.

Input

* Line 1: A single integer, N

* Lines 2..N: These N-1 lines describe the number of cows that precede a given cow in line and have brands smaller than that cow. Of course, no cows precede the first cow in line, so she is not listed. Line 2 of the input describes the number of preceding cows whose brands are smaller than the cow in slot #2; line 3 describes the number of preceding cows whose brands are smaller than the cow in slot #3; and so on.

Output

* Lines 1..N: Each of the N lines of output tells the brand of a cow in line. Line #1 of the output tells the brand of the first cow in line; line 2 tells the brand of the second cow; and so on.

Sample Input

5
1
2
1
0

Sample Output

2
4
5
3
1

 

本来是练习线段树的,结果用一个递推推出来了,明天再用线段树试试

 

递推思想:  已知每头牛前面有几个比自己矮的(题目中序号比自己小的),求他们的高度(他们的序号)为多少

先用一个数组来按原来的序号列出来,即 orignal[] = { 1,2,3,4,5.....n}; 再用一个数组存放后来的顺序,即比他们矮的头数lost[] = {0,1,2,1,0};

从最后一头牛来看,比他矮的有count = lost[i]个, 则从原来的序列orginal【】中选择最小的 count个(必须未被选择过),然后该位置即为 第 count+1 个牛,,

 

#include<iostream>
#include<cstdio>
#include<cstring>

using namespace std;

const int N=8010;

int lost[N],orignal[N],cow[N];
bool visit[N];
int main(){

   	int n,i,j,count,k;
   	scanf("%d",&n);
   	for(i=2;i<=n;i++)
		scanf("%d",&lost[i]);	//  1 2 1 0     第一个是0 不用存	
	for(j=1;j<=n;j++)
		orignal[j]=j;  //  1 2 3 4 5 
	
	memset(visit,0,sizeof(visit));//标志牛是否位置已经确定	
	for(i=n;i>1;i--) 
	{
	//	printf("lost[%d]=%d\n",i,lost[i]);
		count = 0;
		j = 1;
		while(count < lost[i])//从1号牛开始找出未被访问的 lost[i] 个
		{
			while(visit[j])//必须未访问
			{
				j++;
			}	
			count ++;
			j++;
		}
	//	printf("j=%d,org=%d\n",j,orignal[j]);
		while(visit[j]) j++;
		cow[i] = orignal[j];//放置牛,该牛位置确定
		visit[j] = 1;	
		
	}
	for(i=1;i<=n;i++)
	{
		if(!visit[i]) cow[1] = orignal[i];	
	}
	for(k=1;k<=n;k++)
		printf("%d\n",cow[k]);
	
    return 0;
}
/*
5
1
2
1
0
*/