hdu 题目 题目1213 How Many Tables

How Many Tables

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9285    Accepted Submission(s): 4568


Problem Description
Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.
 


 

Input
The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.
 


 

Output
For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.
 


 

Sample Input
2 5 3 1 2 2 3 4 5 5 1 2 5
 


 

Sample Output
2 4
 


 

简单并查集,算根节点数目

 

#include <stdio.h>

int road[10001];

int find1(int a)
{
    while(road[a] != a) //寻找根节点 
     a = road[a];
    return road[a];
}

void merge(int a,int b) // a<b
{
    int x1 = find1(a); //a 的根节点 
    int x2 = find1(b); // b 的根节点 
    if(x2 != x1)
    {    
        road[x2] = x1;     //根节点合并 
    }
}
int main()
{
    int t,n,m,i,a,b,temp,count;
    scanf("%d",&t);
    while(t--)
    {
        
        scanf("%d%d",&n,&m);
        
        for(i=1;i<=n;i++)
            road[i] = i;
        while(m--)
        {
            scanf("%d%d",&a,&b);
            if(b<a) {
                temp = a;
                a = b;
                b = temp;
            }
            merge(a,b);
        }
        count = 0;
        for(i=1; i<=n; i++)
        {
            if(road[i] == i) count++;
        }
        printf("%d\n",count);
    }
    return 0;
}