hdu 题目1251 统计难题 (字典树)

 

统计难题

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 131070/65535 K (Java/Others)
Total Submission(s): 13654    Accepted Submission(s): 5856


Problem Description
Ignatius最近遇到一个难题,老师交给他很多单词(只有小写字母组成,不会有重复的单词出现),现在老师要他统计出以某个字符串为前缀的单词数量(单词本身也是自己的前缀).
 
Input
输入数据的第一部分是一张单词表,每行一个单词,单词的长度不超过10,它们代表的是老师交给Ignatius统计的单词,一个空行代表单词表的结束.第二部分是一连串的提问,每行一个提问,每个提问都是一个字符串.

注意:本题只有一组测试数据,处理到文件结束.
 
Output
对于每个提问,给出以该字符串为前缀的单词的数量.
 
Sample Input
banana band bee absolute acm ba b band abc
 
 
Sample Output
2 3 1 0
 

思路:

1.首先建立字典树,建树的时候统计每个单词出现的次数(这里和NYOJ 题目290 不同)

2.从字典树根节点开始,查找的要查询的字符串最后一个字母,输出其出现次数即可;

3.题目中要求一个空行结束单词表的输入,用:while(gets(s),(strcmp(s,"")!=0))

#include<stdio.h>
#include<string.h>
#include<stdlib.h>

typedef struct dictree
{
    dictree * child[26];
    int cnt;
}dictree;

int num;

void insert (dictree * &root,char * s)
{
    int i,j;
    dictree *p,*q;
    q = root;
    
    for(i=0;i<strlen(s);i++)//在这里要统计每个字母出现次数
    {
        if(q->child[s[i]-'a'])
        {
            
            q = q->child[s[i]-'a'];
            q->cnt++;//已有的字母,次数++
        }    
        else //新的字母cnt = 1;
        {
            p = (dictree *)malloc(sizeof(dictree));
            for(j=0;j<26;j++) p->child[j]=NULL;
            p->cnt = 1;
            
            q->child[s[i]-'a'] = p;
            q = p;
        }
    }
} 

void count(dictree * root,char * s)
{
    dictree * p,* q;
    q = root;
    int i;
    
    for(i=0;i<strlen(s);i++)
    {
        if( !q->child[s[i]-'a'] )//字典树中没有该字母 
        {
            printf("0\n");
            return; 
        }
        else q = q->child[s[i]-'a'];
    }
    if(i==strlen(s))  printf("%d\n",q->cnt);//q指向要查询单词的最后一个字母 
    else
    {
        printf("0\n");
        return;
    } 
}

int main()
{
    int i;
    char s[11];
    
    dictree * root;//根结点初始化 
    root = (dictree *)malloc(sizeof(dictree));
    for(i=0;i<26;i++) root->child[i]=NULL;
    
    while(gets(s),(strcmp(s,"")!=0))//空行结束 单词表的输入
    {
        insert(root,s);
    }
    num = 0;
    while(scanf("%s",s)!=EOF)
        count(root,s);
        
     return 0;
}