hdu 题目1312 Red and Black ( DFS )

Red and Black

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6594    Accepted Submission(s): 4184


Problem Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.
 

 

Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)
 
Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
 
Sample Input
6 9 ....#. .....# ...... ...... ...... ...... ...... #@...# .#..#. 11 9 .#......... .#.#######. .#.#.....#. .#.#.###.#. .#.#..@#.#. .#.#####.#. .#.......#. .#########. ........... 11 6 ..#..#..#.. ..#..#..#.. ..#..#..### ..#..#..#@. ..#..#..#.. ..#..#..#.. 7 7 ..#.#.. ..#.#.. ###.### ...@... ###.### ..#.#.. ..#.#.. 0 0
 
Sample Output
45 59 6 13

 

简单深搜,

1。获取@的位置

2。将@变为‘0’

3。从@的位置开始,设为当前位置,将与当前位置相连的‘.’都变为‘0’

4。计算最后看字符‘0’的个数,

 

#include<iostream>
#include<stdio.h>

using namespace std;

char a[21][21];


void DFS(int x,int y,int w,int h)
{
	if(a[x][y]=='.')  a[x][y]='0';
	
	if(a[x+1][y]=='.'&&x+1<h) DFS(x+1,y,w,h);
	if(a[x-1][y]=='.'&&x-1>=0) DFS(x-1,y,w,h);	
	if(a[x][y+1]=='.'&&y+1<w) DFS(x,y+1,w,h);
	if(a[x][y-1]=='.'&&y-1>=0) DFS(x,y-1,w,h);
}

void count(int w,int h)
{
	int i,j,num=0;
	for(i=0;i<h;i++)
		for(j=0;j<w;j++)
		{
			if(a[i][j] == '0')
				num++;
		}
	printf("%d\n",num);
}

int main() 
{
	int i,j,x,y,w,h;
	while(scanf("%d%d",&w,&h),w&&h)
	{
		getchar();
		for(i=0;i<h;i++)
		{
			for(j=0;j<w;j++)
			{
				scanf("%c",&a[i][j]);
				if(a[i][j]=='@')
				{
					x=i;
					y=j;
				}
			}	
			getchar();	
		}	

		a[x][y]='0';
		DFS(x,y,w,h);	
		count(w,h);
	}
	return 0;
}