POJ 题目1579 Function Run Fun(记忆搜索)

Function Run Fun
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 14815 Accepted: 7659

Description

We all love recursion! Don't we?

Consider a three-parameter recursive function w(a, b, c):

if a <= 0 or b <= 0 or c <= 0, then w(a, b, c) returns:
1

if a > 20 or b > 20 or c > 20, then w(a, b, c) returns:
w(20, 20, 20)

if a < b and b < c, then w(a, b, c) returns:
w(a, b, c-1) + w(a, b-1, c-1) - w(a, b-1, c)

otherwise it returns:
w(a-1, b, c) + w(a-1, b-1, c) + w(a-1, b, c-1) - w(a-1, b-1, c-1)

This is an easy function to implement. The problem is, if implemented directly, for moderate values of a, b and c (for example, a = 15, b = 15, c = 15), the program takes hours to run because of the massive recursion.

Input

The input for your program will be a series of integer triples, one per line, until the end-of-file flag of -1 -1 -1. Using the above technique, you are to calculate w(a, b, c) efficiently and print the result.

Output

Print the value for w(a,b,c) for each triple.

Sample Input

1 1 1
2 2 2
10 4 6
50 50 50
-1 7 18
-1 -1 -1

Sample Output

w(1, 1, 1) = 2
w(2, 2, 2) = 4
w(10, 4, 6) = 523
w(50, 50, 50) = 1048576
w(-1, 7, 18) = 1

 

经典记忆化搜索:就是将每次搜索的结果保存在一个数组内,计算过的结果不必再重复计算;

 

 

#include <stdio.h>
#include <string.h>

int vis[22][22][22];//用来保存每次递归调用的结果

int w(int a,int b,int c)
{
	if (a<=0 || b <= 0 || c<=0) return 1;		
	if (a>20 || b > 20 || c>20)     return	vis[20][20][20] = w(20, 20, 20);//直接返回vis[20][20][20]里面的值 
	if(vis[a][b][c]) return vis[a][b][c];//如果已经计算过,直接返回		
	if (a<b  && b < c) return	vis[a][b][c] = w(a,b,c-1) + w(a,b-1,c-1) - w(a,b-1,c) ; //每次返回前保存结果在vis[][][];
	else return  vis[a][b][c] = w(a-1,b,c) + w(a-1,b-1,c) + w(a-1,b,c-1) - w(a-1,b-1,c-1); 
}
int main()
{
	int ans,a,b,c;
	while(scanf("%d%d%d",&a,&b,&c),!(a==-1&&b==-1&& c==-1))
	{
		memset(vis,0,sizeof(vis));
	
		printf("w(%d, %d, %d) = %d\n",a,b,c,w(a,b,c));
	}
	return 0;
}