hdu 题目1078FatMouse and Cheese(记忆搜索)

FatMouse and Cheese

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3706    Accepted Submission(s): 1472


Problem Description
FatMouse has stored some cheese in a city. The city can be considered as a square grid of dimension n: each grid location is labelled (p,q) where 0 <= p < n and 0 <= q < n. At each grid location Fatmouse has hid between 0 and 100 blocks of cheese in a hole. Now he's going to enjoy his favorite food.

FatMouse begins by standing at location (0,0). He eats up the cheese where he stands and then runs either horizontally or vertically to another location. The problem is that there is a super Cat named Top Killer sitting near his hole, so each time he can run at most k locations to get into the hole before being caught by Top Killer. What is worse -- after eating up the cheese at one location, FatMouse gets fatter. So in order to gain enough energy for his next run, he has to run to a location which have more blocks of cheese than those that were at the current hole.

Given n, k, and the number of blocks of cheese at each grid location, compute the maximum amount of cheese FatMouse can eat before being unable to move.
 


 

Input
There are several test cases. Each test case consists of

a line containing two integers between 1 and 100: n and k
n lines, each with n numbers: the first line contains the number of blocks of cheese at locations (0,0) (0,1) ... (0,n-1); the next line contains the number of blocks of cheese at locations (1,0), (1,1), ... (1,n-1), and so on.
The input ends with a pair of -1's.
 


 

Output
For each test case output in a line the single integer giving the number of blocks of cheese collected.
 


 

Sample Input
3 1 1 2 5 10 11 6 12 12 7 -1 -1
 


 

Sample Output
37

 

 

 

类似于POJ1088 滑雪问题,也是经典记忆搜索,

#include<stdio.h>
#include <string.h>
#define N 110
int n,k;

int a[N][N],v[N][N];

int DFS(int i,int j)
{
	
	if(v[i][j]) return v[i][j];//上次的记忆
	
	int temp,max=0,x;
	for(x=1;x<=k;x++)//四个方向各走x步,找最大值 
	{
		if(i+x<n && a[i+x][j]>a[i][j]   ){
			temp = DFS(i+x,j) ;
			max = temp>max?temp:max;
		}
		if(j+x<n && a[i][j+x]>a[i][j] ){
			temp = DFS(i,j+x) ;
			max = temp>max?temp:max;
		}
		if(i-x>=0 && a[i-x][j]>a[i][j] ){
			temp = DFS(i-x,j) ;
			max = temp>max?temp:max;
		}
		if(j-x>=0 && a[i][j-x]>a[i][j] ){
			temp = DFS(i,j-x) ;
			max = temp>max?temp:max;
		}	
	}
		
	v[i][j] = max+ a[i][j];//记录当前点到四个方向的最大值
	return  v[i][j];
	
}

int main()
{
	int i,j;
	while(scanf("%d%d",&n,&k),n!=-1 && k!=-1)	
	{	
		for(i=0;i<n;i++) 
			for(j=0;j<n;j++)
				scanf("%d",&a[i][j]);
		int temp,max=0;
		memset(v,0,sizeof(v));
		temp = DFS(0,0);//qidian
		printf("%d\n",temp);
	}
	return 0;
}