题目1045 Fire Net (DFS)

Fire Net

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4961    Accepted Submission(s): 2784

Problem Description
Suppose that we have a square city with straight streets. A map of a city is a square board with n rows and n columns, each representing a street or a piece of wall. 

A blockhouse is a small castle that has four openings through which to shoot. The four openings are facing North, East, South, and West, respectively. There will be one machine gun shooting through each opening. 

Here we assume that a bullet is so powerful that it can run across any distance and destroy a blockhouse on its way. On the other hand, a wall is so strongly built that can stop the bullets. 

The goal is to place as many blockhouses in a city as possible so that no two can destroy each other. A configuration of blockhouses is legal provided that no two blockhouses are on the same horizontal row or vertical column in a map unless there is at least one wall separating them. In this problem we will consider small square cities (at most 4x4) that contain walls through which bullets cannot run through. 

The following image shows five pictures of the same board. The first picture is the empty board, the second and third pictures show legal configurations, and the fourth and fifth pictures show illegal configurations. For this board, the maximum number of blockhouses in a legal configuration is 5; the second picture shows one way to do it, but there are several other ways. 



Your task is to write a program that, given a description of a map, calculates the maximum number of blockhouses that can be placed in the city in a legal configuration. 
 

Input
The input file contains one or more map descriptions, followed by a line containing the number 0 that signals the end of the file. Each map description begins with a line containing a positive integer n that is the size of the city; n will be at most 4. The next n lines each describe one row of the map, with a '.' indicating an open space and an uppercase 'X' indicating a wall. There are no spaces in the input file. 
 

Output
For each test case, output one line containing the maximum number of blockhouses that can be placed in the city in a legal configuration.
 

Sample Input
4 .X.. .... XX.. .... 2 XX .X 3 .X. X.X .X. 3 ... .XX .XX 4 .... .... .... .... 0
 

Sample Output
5 1 5 2 4
 


1.首先把 n*n 的大方格里的每个小方格编号 i(0,1,2,3,4,5....n*n-1),每一小格的横纵坐标分别为 row = i/n;   col = i%n;

2.从一号格格开始放置,判断能否放置,若能,则将能放置的元素个数+1,继续判断第二个格格,循环直到所有的都判断完。取最大值

3.判断该位置能否放置,必须该元素所在行和列没有放置过元素(在遇到‘X’之前)



#include<stdio.h>
#include<string.h>

char a[4][4]; bool vis[4][4];
int n,maxnum;

bool place(int x,int y)//判断该位置是否能放置
{
    for(int i=x-1; i>=0 && a[i][y]!='X';i--)
        if(vis[i][y]) return false;    

    for(int j=y-1; j>=0 && a[x][j]!='X';j--)
        if(vis[x][j]) return false;    
    
    return true;
}
void DFS(int i,int num)
{
    if(i== n*n){//已经判断完每一格
        maxnum = maxnum>num ? maxnum : num;
        return;
    }    
    else{
        int row = i/n;   int col = i%n;
        
        if(a[row][col]=='.' && place(row,col)){
            vis[row][col] = 1;
            DFS(i+1,num+1);
            vis[row][col] = 0;
        }
        DFS(i+1,num);
    }
}
int main()
{
    while(scanf("%d",&n),n)
    {
        for(int i=0;i<n;i++)    scanf("%s",a[i]);
        maxnum=0;
        memset(vis,0,sizeof(vis));
        DFS(0,0);
        printf("%d\n",maxnum);        
    }
    return 0;
}