poj 题目2398 Toy Storage (简单计算几何)

Toy Storage
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 3299 Accepted: 1887

Description

Mom and dad have a problem: their child, Reza, never puts his toys away when he is finished playing with them. They gave Reza a rectangular box to put his toys in. Unfortunately, Reza is rebellious and obeys his parents by simply throwing his toys into the box. All the toys get mixed up, and it is impossible for Reza to find his favorite toys anymore.
Reza's parents came up with the following idea. They put cardboard partitions into the box. Even if Reza keeps throwing his toys into the box, at least toys that get thrown into different partitions stay separate. The box looks like this from the top:

We want for each positive integer t, such that there exists a partition with t toys, determine how many partitions have t, toys.

Input

The input consists of a number of cases. The first line consists of six integers n, m, x1, y1, x2, y2. The number of cardboards to form the partitions is n (0 < n <= 1000) and the number of toys is given in m (0 < m <= 1000). The coordinates of the upper-left corner and the lower-right corner of the box are (x1, y1) and (x2, y2), respectively. The following n lines each consists of two integers Ui Li, indicating that the ends of the ith cardboard is at the coordinates (Ui, y1) and (Li, y2). You may assume that the cardboards do not intersect with each other. The next m lines each consists of two integers Xi Yi specifying where the ith toy has landed in the box. You may assume that no toy will land on a cardboard.

A line consisting of a single 0 terminates the input.

Output

For each box, first provide a header stating "Box" on a line of its own. After that, there will be one line of output per count (t > 0) of toys in a partition. The value t will be followed by a colon and a space, followed the number of partitions containing t toys. Output will be sorted in ascending order of t for each box.

Sample Input

4 10 0 10 100 0
20 20
80 80
60 60
40 40
5 10
15 10
95 10
25 10
65 10
75 10
35 10
45 10
55 10
85 10
5 6 0 10 60 0
4 3
15 30
3 1
6 8
10 10
2 1
2 8
1 5
5 5
40 10
7 9
0

Sample Output

Box
2: 5
Box
1: 4
2: 1

 

更刚才那道题题目几乎一样,只不过这个需要将边进行排序,然后计算每个区域的点的个数;

 

#include<iostream> 
#include<stdio.h>
#include<algorithm>
#define N 1005
using namespace std;
struct bian{
	int up;
	int down;
};
bian box[N];
int cnt[N];

bool cmp(bian a,bian b){
	if(a.up<b.up) return true;
	return false;
}
int main()
{
	int n,m,x1,y1,x2,y2,i,j,xj,yj,ui,li;
	while(scanf("%d",&n),n)
	{
		scanf("%d%d%d%d%d",&m,&x1,&y1,&x2,&y2);
		box[n].up= box[n].down = x2;
		for(i=0;i<n;i++){
			scanf("%d%d",&ui,&li);
			box[i].up = ui;  box[i].down=li; 
		}
		sort(box,box+n+1,cmp); //这里需要排序 
		for(i=0;i<=n;i++) cnt[i]=0;
		for(i=0;i<m;i++){
			scanf("%d%d",&xj,&yj);
			for(j=0;j<=n;j++)
			{			
				int b1x = box[j].up ;
				int b2x = box[j].down;
				
				if((b2x-b1x)*(yj-y1)-(y2-y1)*(xj-b1x)<0 ) { //判断点与当前边的关系 
					cnt[j]++; break;	
				}	
			}
		}
		sort(cnt,cnt+n+1); //个数排序 
		printf("Box\n");	
		for(i=1;i<=n;i++){
			if(cnt[i-1]){	
				int sum = 1;
			
				while(cnt[i]==cnt[i-1]) {
					i++;sum++;
				}
				printf("%d: %d\n",cnt[i-1],sum);
				if(i==n)	printf("%d: 1\n",cnt[i]); //最后的单独一个 
			}		
		}
	}
	return 0;
}