hdu 题目 1384 Wall(凸包)

Graham求凸包:https://www.2cto.com/kf/201301/184235.html

 

Wall

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2497    Accepted Submission(s): 695


Problem Description
Once upon a time there was a greedy King who ordered his chief Architect to build a wall around the King's castle. The King was so greedy, that he would not listen to his Architect's proposals to build a beautiful brick wall with a perfect shape and nice tall towers. Instead, he ordered to build the wall around the whole castle using the least amount of stone and labor, but demanded that the wall should not come closer to the castle than a certain distance. If the King finds that the Architect has used more resources to build the wall than it was absolutely necessary to satisfy those requirements, then the Architect will loose his head. Moreover, he demanded Architect to introduce at once a plan of the wall listing the exact amount of resources that are needed to build the wall.
Your task is to help poor Architect to save his head, by writing a program that will find the minimum possible length of the wall that he could build around the castle to satisfy King's requirements.



The task is somewhat simplified by the fact, that the King's castle has a polygonal shape and is situated on a flat ground. The Architect has already established a Cartesian coordinate system and has precisely measured the coordinates of all castle's vertices in feet.
 

Input
The first line of the input file contains two integer numbers N and L separated by a space. N (3 <= N <= 1000) is the number of vertices in the King's castle, and L (1 <= L <= 1000) is the minimal number of feet that King allows for the wall to come close to the castle.

Next N lines describe coordinates of castle's vertices in a clockwise order. Each line contains two integer numbers Xi and Yi separated by a space (-10000 <= Xi, Yi <= 10000) that represent the coordinates of ith vertex. All vertices are different and the sides of the castle do not intersect anywhere except for vertices.
 

Output
Write to the output file the single number that represents the minimal possible length of the wall in feet that could be built around the castle to satisfy King's requirements. You must present the integer number of feet to the King, because the floating numbers are not invented yet. However, you must round the result in such a way, that it is accurate to 8 inches (1 foot is equal to 12 inches), since the King will not tolerate larger error in the estimates.

This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.
 

Sample Input
1 9 100 200 400 300 400 300 300 400 300 400 400 500 400 500 200 350 200 200 200
 

Sample Output
1628
 


1.寻找凸包的边上的点,求出周长

2.周长加上 给出的半径的 圆弧和(即一个圆周)


#include<algorithm>
#include<math.h>
#include<stdio.h>
#include<string.h>
#define PI 3.1415926

using namespace std;

struct point{
    int x,y;
}p[1005];
bool vis[1005];

bool cmp(point a,point b){
    if(a.x<b.x) return 1;
    else if(a.x==b.x){
        if(a.y<b.y) return 1;
        else return 0;
    }
    else return 0;
}
double cross(point a,point b,point c){
    return (b.x-a.x)*(c.y-b.y) - (b.y-a.y)*(c.x-b.x);
}
double dis(point A,point B)  
{  
    return sqrt((double)((B.x-A.x)*(B.x-A.x)+(B.y-A.y)*(B.y-A.y)));  
}  

int main(){


    int rear,front;
    int que[10000];
    int t,n,l,i,temp;
    scanf("%d",&t);
    while(t--){
        scanf("%d%d",&n,&l);                                 
        for(i=0;i<n;i++) 
            scanf("%d %d",&p[i].x,&p[i].y);
    
        sort(p,p+n,cmp);//排序,找到第一个在凸包上的点 p[0] 

        memset(vis,0,sizeof(vis)); 
        vis[0]=1;
        
        temp =rear = front =0;
              
        while(1){
            
            int t = -1;
            for(int j=0;j<n;j++){
                if(!vis[j]) {
                    t = j;
                    break;
                }               
            }    
            if(t==-1) break; //全部访问完毕退出 
            
            for(i=0;i<n;i++){
                if( (cross(p[temp],p[t],p[i])>0 
                || (cross(p[temp],p[t],p[i])==0 
                && dis(p[temp],p[i]) > dis(p[temp],p[t])))){
                    t = i;
                }
            }
            
            if(vis[t]) break;
            que[rear++]= t;
            vis[t] = 1;
            temp = t;
        }
        
        que[rear++] = 0;
        double sum=0;
        temp = 0; int in;
        while(front != rear){ //计算凸包边长和
            in = que[front++];
            sum += dis(p[in],p[temp]);
            temp = in;                                    
        }
        
        printf("%.0f\n",sum+PI*l*2  );
        if(t) printf("\n");
    }
    return 0;
}