hdu 题目1907 Johu (取火柴游戏,取最后一个胜)

John

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 2179    Accepted Submission(s): 1175


Problem Description
Little John is playing very funny game with his younger brother. There is one big box filled with M&Ms of different colors. At first John has to eat several M&Ms of the same color. Then his opponent has to make a turn. And so on. Please note that each player has to eat at least one M&M during his turn. If John (or his brother) will eat the last M&M from the box he will be considered as a looser and he will have to buy a new candy box.

Both of players are using optimal game strategy. John starts first always. You will be given information about M&Ms and your task is to determine a winner of such a beautiful game.

 

Input
The first line of input will contain a single integer T – the number of test cases. Next T pairs of lines will describe tests in a following format. The first line of each test will contain an integer N – the amount of different M&M colors in a box. Next line will contain N integers Ai, separated by spaces – amount of M&Ms of i-th color.

Constraints:
1 <= T <= 474,
1 <= N <= 47,
1 <= Ai <= 4747

 

Output
Output T lines each of them containing information about game winner. Print “John” if John will win the game or “Brother” in other case.

 

Sample Input
2 3 3 5 1 1 1
 

Sample Output
John Brother
 

 先者必败条件: 奇异局势&& 充裕堆数目>=2   或者  非奇异局势&& 孤单堆数目==n


/***************************
# 2013-8-23 17:04:27 
# Time: MS   Memory: KB
# Author: zyh
# Status: Accepted
***************************/ 

#include<iostream>
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<algorithm>

using namespace std;

int main()
{
    int n,m,t,sum,cnt1,cnt2,flag,i,a[48];
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n); 
        for(sum=cnt1=cnt2=0,i=0;i<n;i++){
            scanf("%d",&a[i]);
            if(a[i]>1) cnt1++; //充裕堆数目 
            else cnt2++; //孤单堆数目 
            sum ^= a[i];
        }

        if((sum==0&&cnt1>=2) || (sum && cnt2==n)  )printf("Brother\n");
        else printf("John\n");
         
    }
    return 0;
}