hdu 题目2147 kiki's game (组合游戏,必败点和必胜点)

kiki's game

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 40000/1000 K (Java/Others)
Total Submission(s): 5383    Accepted Submission(s): 3163


Problem Description
Recently kiki has nothing to do. While she is bored, an idea appears in his mind, she just playes the checkerboard game.The size of the chesserboard is n*m.First of all, a coin is placed in the top right corner(1,m). Each time one people can move the coin into the left, the underneath or the left-underneath blank space.The person who can't make a move will lose the game. kiki plays it with ZZ.The game always starts with kiki. If both play perfectly, who will win the game?
 

Input
Input contains multiple test cases. Each line contains two integer n, m (0<n,m<=2000). The input is terminated when n=0 and m=0.

 

Output
If kiki wins the game printf "Wonderful!", else "What a pity!".
 

Sample Input
5 3 5 4 6 6 0 0
 

Sample Output
What a pity! Wonderful! Wonderful!



必胜点:首先( n , 1)   ,  然后其他必胜点: 该点的左,下,左下,必须都为必败点;

初始代码:Memory Limit Exceeded


#include<stdio.h>
#include<string.h>


bool a[2005][2005];

int main()
{
    int n,m,i,j;
    
    
        memset(a,0,sizeof(a));
    
        a[2000][1]=1;
        for(i=2000;i>=1;i--){
            for(j=1;j<=2000;j++){
                if(!a[i][j]){
                    if(((i+1>2000 && j-1<1)|| a[i+1][j-1]==0) && 
                    (i+1>2000 || a[i+1][j]==0) && (j-1<1 || a[i][j-1]==0 )  )
                     a[i][j] = 1;
                }
            }
        }
    

    while(scanf("%d%d",&n,&m),n&&m)
    {
        if(!a[2000-n+1][m]) printf("Wonderful!\n");
        else printf("What a pity!\n");
    }
    return 0;
} 




将终点(必胜点)看做1,1;周围其他必胜点必须经过两步才能到达,   必胜点 横纵坐标必须都为 奇数




#include<stdio.h>
int main ()
{
   int a,b;
   while(~scanf("%d%d",&a,&b))
   {
      if(!a&&!b)
      break;
      if(!(a&1)||!(b&1))
      printf("Wonderful!\n");
      else
      printf("What a pity!\n");
   }
   return 0;
}