hdu 题目1398 Square Coins (母函数及其应用)

Square Coins

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6828    Accepted Submission(s): 4613


Problem Description
People in Silverland use square coins. Not only they have square shapes but also their values are square numbers. Coins with values of all square numbers up to 289 (=17^2), i.e., 1-credit coins, 4-credit coins, 9-credit coins, ..., and 289-credit coins, are available in Silverland. 
There are four combinations of coins to pay ten credits: 

ten 1-credit coins,
one 4-credit coin and six 1-credit coins,
two 4-credit coins and two 1-credit coins, and
one 9-credit coin and one 1-credit coin. 

Your mission is to count the number of ways to pay a given amount using coins of Silverland.
 

Input
The input consists of lines each containing an integer meaning an amount to be paid, followed by a line containing a zero. You may assume that all the amounts are positive and less than 300.
 

Output
For each of the given amount, one line containing a single integer representing the number of combinations of coins should be output. No other characters should appear in the output. 
 

Sample Input
2 10 30 0
 

Sample Output
1 4 27
 



每个元素还是无限个

只不过每一括号表达式的项的 x 次幂 变化了

母函数 G(x) = (1+ x + x^2 + x^3 +...)(1+ x^4 + x^8 +...)(1+ x^9 + x^18+...)...


/***************************
# 2013-8-26 19:22:19 
# Time: 0MS   Memory:228 KB
# Author: zyh
# Status: Accepted
***************************/ 

#include<iostream>
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<algorithm>

using namespace std;

int main()
{
    int n,i,j,k,c1[305],c2[305]; //第一次数组开300 WA了,,
    while(scanf("%d",&n),n)
    {
        for(i=0;i<=n;i++){
            c1[i] = 1;  //这里初始化应该是第一个括号表达式里 x次幂 的系数
            c2[i] = 0;
        }
        for(i=2;i*i<=n;i++){ //表达式个数,从第二个表达式开始计算
            for(j=0;j<=n;j++){
                for(k=0;j+k<=n;k+=(i*i)){
                    c2[j+k] += c1[j];
                }
            }
            for(j=0;j<=n;j++){
                c1[j] = c2[j];
                c2[j] = 0;
            }
        }
        printf("%d\n",c1[n]);
    }
    return 0;
}