hdu 题目1028 Ignatius and the Princess III(母函数及其应用)

Ignatius and the Princess III

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 10219    Accepted Submission(s): 7244


Problem Description
"Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says.

"The second problem is, given an positive integer N, we define an equation like this:
  N=a[1]+a[2]+a[3]+...+a[m];
  a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
  4 = 4;
  4 = 3 + 1;
  4 = 2 + 2;
  4 = 2 + 1 + 1;
  4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"
 

Input
The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.
 

Output
For each test case, you have to output a line contains an integer P which indicate the different equations you have found.
 

Sample Input
4 10 20
 

Sample Output
5 42 627
 

基本的母函数应用:

1的个数无限个

2的个数无限个

所有元素个数都是无限个

故母函数 G(x) = (1+ x + x^2 + x^3 + ...)(1+ x^2 + x^4 +...) (1+x^3 + x^6 + x^9 +...) (1+ x^4 +).....( 1+ x^n + x^2n +.....)




/***************************
# 2013-8-26 18:18:57 
# Time: 15MS   Memory: 228KB
# Author: zyh
# Status: Accepted
***************************/ 


#include<stdio.h>

int main()
{
    int n,i,j,k,c1[150],c2[150];
    
    while(scanf("%d",&n)!=EOF)
    {
        for(i=0;i<=n;i++){
            c1[i]=1;
            c2[i]=0;
        }
        for(i=2;i<=n;i++){ //这里的 n 是 ()括起来的表达式的个数
            for(j=0;j<=n;j++){  //这里的n 是括号里每个表达式的 项的个数
                for(k=0;k+j<=n;k+=i){ //这里的 n 是所求结果的 最高次幂
                  c2[j+k] += c1[j];    
                }
            }
            for(j=0;j<=n;j++){
                c1[j] = c2[j];
                c2[j] = 0;
            }
        }
        printf("%d\n",c1[n]);
    }
    return 0;
}